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A Basic Guide to 
Modeling Landscapes 
in Google® SketchUp®  

A DS|Sketch 3D User Guide ɀ Volume 2  

This guide will take you through the steps of creating a 3D model of a 
landscape in Google® SketchUp® using DS|Sketch3D tools, components 
and materials. This guide is mainly relevant for DS|Design and AutoCAD 

users although anyone who creates their base design right in Google 
SketchUp may benefit from this guide as well. 
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3ÕÍÍÁÒÙ 
 

This guide is intended to give a basic guideline to follow in order to create an average 3D model using 

Google® SketchUp® (hereafter call SketchUp) as the modeling tool and DS|Sketch3D. The following basic 

steps will be explained: 

Step 1. Download the plugins, components and material textures you need from the 

DS|Sketch3D Download Site 

Step 2. Bring your CAD drawing into SketchUp 

Step 3. Clean up the CAD drawing 

Step 4. Model the house (or building) and roof 

Step 5. Model the terrain 

Step 6. Apply material textures 

Step 7. Replacing 2D Symbols with 3D Models 

Step 8. Create Scenes 

Step 9. Render your Model for Presentation 

"ÁÓÉÃ 3ËÅÔÃÈ5Ð 4ÏÏÌÓ 9ÏÕ .ÅÅÄ ÔÏ +ÎÏ× 
 

In order to follow the process explained in this guide you need to become familiar with the following 

tools: 

Icon Name Description 

 
Pan tool Navigation tool for panning around the model 

 
Orbit tool Navigation tool to rotate your view 

 
Select tool Tool for selecting objects in the model 

 
Eraser Tool for removing objects in the model 

 
Move tool Tool for moving or copying objects 

 
Push/Pull Tool for pushing  or pulling faces 
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3ÔÅÐ ρȡ $Ï×ÎÌÏÁÄ ÙÏÕÒ 0ÌÕÇÉÎÓȟ #ÏÍÐÏÎÅÎÔÓ ÁÎÄ 
-ÁÔÅÒÉÁÌ 4ÅØÔÕÒÅÓ 
 

Before creating 3D models in Google SketchUp make sure you have the proper tools, 3D libraries and 

textures. You can download these from the DS|Sketch3D Download Website: 

https://sketch3d.dynascape.com  

Plugin s: 

If you are using a CAD drawing (DynaSCAPE or AutoCAD) as the base for your 3D model, you will save 

yourself a considerable amount of time if you download the CAD Cleanup Scripts plugin from the 

Plugins page. For help in downloading and installing plugins go the FAQ page of the DS|Sketch3D 

website. 

Components:  

Your best source for landscape components is the DS|Sketch3D Download Website, where you will find 

мллΩǎ ƻŦ ƳƻŘŜƭǎ ƻŦ ǇƭŀƴǘǎΣ ǊƻŎƪǎΣ ǇƻƴŘǎΣ Ǉƻols etc. Download the models you need. For help in 

downloading and installing components go the FAQ page of the DS|Sketch3D website. 

Material Textures  

The DS|Sketch3D Download Website has a number of landscape-specific material texture libraries that 

you can download and use in your SketchUp model. . For help in downloading and installing material 

textures go the FAQ page of the DS|Sketch3D website. 

3ÔÅÐ ςȡ "ÒÉÎÇ ÙÏÕÒ #!$ $ÒÁ×ÉÎÇ ÉÎÔÏ 3ËÅÔÃÈ5Ð 

Choose your Starting Point  

From DynaSCAPE: 

If you are using the latest version of DS|Design (5.5 or later) you can export directly to SketchUp format. 

The file created can be opened with SketchUp without any special import function. 

From AutoCAD or other:  

If you are using AutoCAD or another CAD program that can convert to a .dwg, you can import your CAD 

drawing into SketchUp. However, importing .dwg files is only available with the Pro version of SketchUp. 

From  scratch:  

You can also begin your ŘǊŀǿƛƴƎ ŦǊƻƳ ǎŎǊŀǘŎƘ ǊƛƎƘǘ ƛƴ {ƪŜǘŎƘ¦ǇΦ ¸ƻǳ ǿƻƴΩǘ ƴŜŜŘ ǘƻ ǇŜǊŦƻǊƳ ŀƴȅ ŎƭŜŀƴǳǇ 

so skip to the 3rd step:  Model the House (or Building) and Roof 

https://sketch3d.dynascape.com/
http://www.dynascape.com/sketch3D.html
http://www.dynascape.com/sketch3D.html
http://www.dynascape.com/sketch3D.html
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3ÔÅÐ σȡ #ÌÅÁÎ 5Ð ÔÈÅ )ÍÐÏÒÔÅÄ #!$ $ÒÁ×ÉÎÇ 
 

If your drawing was converted to SketchUp from DS|Design or imported as an AutoCAD file, you will 

need to do some cleanup before you can begin modeling. All files that are converted or imported from 

CAD are changed in a way that prevents SketchUp from creating faces with the CAD geometry. Faces are 

needed in order to create a 3D object and to apply a material texture to. 

Follow these steps to clean up the drawing: 

1. Imported AutoCAD drawing usually come in as a group which will need to be exploded. The 

DynaSCAPE CAD Cleanup plugin will not touch geometry inside groups or components. 

2. Begin by running the DynaSCAPE CAD Cleanup plugin you downloaded from the DS|Sketch3D 

Download Website. It will be located in Google SketchUp under the Plugins menu. Select 

DynaSCAPE Tools and then Run CAD Cleanup (All). 

 

5ƻƴΩǘ ƘŀǾŜ ǘƘƛǎ ǇƭǳƎƛƴΚ If you have not downloaded this plugin, go to 

https://sketch3d.dynascape.com/ , click on the Plugins menu in the left side panel and choose 

the CAD Cleanup Scripts plugin to download. 

CŀƴΩǘ ǎŜŜ ǘƘŜ tƭǳƎƛƴǎ ƳŜƴǳΚ LŦ ȅƻǳ ŎŀƴΩǘ ǎŜŜ ǘƘŜ ǇƭǳƎƛƴǎ ƳŜƴǳ ȅƻǳ ǿƛƭƭ ƴŜŜŘ ǘƻ ŀŎǘƛǾŀǘŜ ƛǘΦ Dƻ 

the DS|Sketch3D FAQ page and browse to the section called How to enable the Plugins menu. 

3. The cleanup script will run automatically, scanning the drawing and repairing any problems that 

may exist and then turn every closed area that it can into faces. For large drawings this may take 

a few minutes and it may appear that SketchUp is not responding ς be patient! When the 

cleanup is complete a dialogue box will appear showing the results. Click OK to continue. 

https://sketch3d.dynascape.com/
http://www.dynascape.com/sketch3D.html
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4. Check your drawing to see if there still are any faces that were not created. Try running the 

Cleanup script again or you may need to manually close open areas by adding lines where gaps 

where too large for the script to fix. Faces are identified by the dot hatch that appears when you 

select them. 

    

Before Cleanup     After Cleanup 

Tip: When using the DS|Design export to SketchUp format, the default style has a purple Back color  and 

a yellow Selected color. To change this go to the Window menu, select Styles and pick one of the default 

styles. The style called Default Style is a good one to use.   
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3ÔÅÐ τȡ -ÏÄÅÌ ÔÈÅ (ÏÕÓÅ ɉÏÒ "ÕÉÌÄÉÎÇɊ ÁÎÄ 2ÏÏÆ 
 

Modeling the house should be and fast and efficient since it is not what you are trying to sell with your 

landscape model. Using the proper techniques and tools you should be able to do this quickly.  

Download the Roof Tool:   

Before you start, makŜ ǎǳǊŜ ȅƻǳ ƘŀǾŜ ǘƘŜ ǊƻƻŦ ƳŀƪƛƴƎ ǘƻƻƭ ƛƴ ȅƻǳǊ ǇƭǳƎƛƴǎ ƭƛǎǘΦ LŦ ȅƻǳ ŘƻƴΩǘΣ Ǝƻ ǘƻ ǘƘŜ 

Ruby Depot website and download the roof plugin called Roof-v2-1. 

Follow these steps to build a simple roof: 

1. Apply a material texture to the house face that best represents the exterior walls of your house. 

By applying a texture to house surface first SketchUp will automatically apply the texture to all 

the walls when you pull it into a 3D shape. 

http://rld.crai.archi.fr/rld/
http://rhin.crai.archi.fr/rld/plugin_details.php?id=339
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2. Next, use the Push/Pull tool to pull the house surface up into a 3D shape. Watch the Value 

Control Box at the bottom right corner of the screen to help you pull to the desired height or 

just enter the value on your keyboard manually and hit [Enter]. 
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3. Before using the Roof tool, erase all extra lines in the house wall that are not needed. The roof 

tool may not work if you leave them. 

 

4. Highlight the roof with the Select tool and then go to the Plugins menu and select wƻƻŦΧ There 

are a number of roof styles to choose from. The first style, Hipped Roof, is a common style to 

use. For more information click on the Help option on the roof menu to open the Roof Help 

page. 
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5. When selected, a modifier will appear allowing you to set some parameters. The defaults will 

work for many roofs. 

 

6. Click OK. The roof will be created for you. Refer to Roof Help if you are having problems.  
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7. The created roof comes in as a group. To apply a texture, double-click on the roof to open the 

group for editing. Once opened you can apply a roof shingle texture to the roof surfaces to 

complete the roof. 

 

8. Next find the door and window components. All the DS|Sketch3D doors and windows are set to 

automatically glue to any surface and cut the opening in the wall, making it easy to place and 

move them. If you downloaded them from the DS|Sketch3D Download Website, they should be 

in your components folder. Go to your Window menu and select Components to open the 

Components Browser.  

 

9. Click on the Navigation button and choose Component (see image below).  
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Your door and window components should be found here if you followed the instruction on the 

DS|Sketch3D FAQ page. Choose the components that you need and place them on the house. If 

your house has a front porch, place the front door in the approximate location. Once the porch 

is created the door can easily be adjusted.  The DS|Sketch3D doors consist of 2 separate 

components: a frame and door. There are a number of frame and door styles and combinations 

to choose from. 

 

 

http://www.dynascape.com/sketch3D.html
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3ÔÅÐ υȡ -ÏÄÅÌ ÔÈÅ 4ÅÒÒÁÉÎ 
 

Modeling the terrain is generally a more advance process but, as outlined in Step 5, simple grade 

changes like steps and front porches can easily be accomplished with the Push/Pull tool. To create a 

porch and step(s) follow these steps: 

1. Apply textures to the porch and step(s) first. 

 

2. Then, using the Push/Pull tool, pull the porch and step(s) up to the appropriate height. 

 

3. Adjust the door height as needed. 
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3ÔÅÐ φȡ !ÐÐÌÙ 4ÅØÔÕÒÅÓ 
 

Once the terrain has been modeled it is time to apply textures to the rest of the surfaces in the model. 

 

If you have created shapes for your hedges, apply one of the DS|Sketch3D hedge textures. Apply hedge 

textures (with trunks) first and then pull the hedge(s) to the desired height. To finish, apply the matching 

hedge texture (without trunks) to the top of the hedge(s). 
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3ÔÅÐ χȡ 2ÅÐÌÁÃÅ ς$ 3ÙÍÂÏÌÓ ×ÉÔÈ σ$ -ÏÄÅÌÓ 
 

If you are developiƴƎ ȅƻǳǊ ƳƻŘŜƭ ŦǊƻƳ ŀ /!5 ŘǊŀǿƛƴƎ ǘƘŀǘ Ƙŀǎ ǎȅƳōƻƭǎ ό5ȅƴŀ{/!t9 ƭƛōǊŀǊȅ ΨŦƛƎǳǊŜǎΩ ƻǊ 

!ǳǘƻ/!5 ΨōƭƻŎƪǎΩύΣ ǘƘƛǎ ǎǘŜǇ ƛǎ ǘƘŜ Ƴƻǎǘ Ŧǳƴ ŀƴŘ Ŏŀƴ ǘǊŀƴǎŦƻǊƳ ȅƻǳǊ ƳƻŘŜƭ ǉǳƛŎƪƭȅΦ 

If you do not have these symbols on your drawing you will have to insert the 3D plant components 

manually. 

If you grouped your figures in your CAD program you will have to insert the 3D plant components 

manually as well. Keep this in mind when preparing your CAD drawing. 

To replace your 2D symbols with 3D models follow these steps: 

1. Zoom in to your model to a plant symbol and, using your Select tool, left-click on it to highlight it 

and then right-click. 

2. In the menu that appears choose Reload. 
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3. Navigate to the folders containing your Components (if you followed the instructions in the 

DS|Sketch3D website FAQ page, this should be C:\ Program Files [(x86)]\ Google\ Google 

SketchUp 8\ Components). Select the component you wish to replace the symbol with and click 

Open. 

 

The 2D symbol will now be replaced with the 3D (or 2D) component. 
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4. Continue this process with the remaining symbols in the model. Note that when you select a 

symbol to replace, SketchUp will replace all the symbols that are the same. It is important to 

remember, when creating your CAD drawing, that you use unique symbols for each plant type. 

 

5. You can use the same process to replace other symbols as well such as rocks and furniture. 

{ȅƳōƻƭǎ ǎǳŎƘ ŀǎ Ǉƻƻƭǎ ŀƴŘ ǇƻƴŘǎ ƘƻǿŜǾŜǊ ǿƛƭƭ ƭƻǎŜ ǘƘŜƛǊ ŀōƛƭƛǘȅ ǘƻ ΨŎǳǘΩ ǘƘŜ ǎǳǊŦŀŎŜ ƛŦ ōǊƻǳƎƘǘ ƛƴ 
















